Home
Products
Community
Manuals
Contact
Login or Signup

3DSMAX sub-frames control..

Miscellaneous Forums/Content Creation Tools/3DSMAX sub-frames control..

Naughty Alien(Posted 1+ years ago) #1
..well..problem is simple but i havent found any 'cure' for it, and i did google and read multiple docs and so on..so, maybe some of you guys can help me...basically, i want to remove sub-keys autogenerated in between two nearest animation keys...or better say, i dont want them to be created..i want my animated object simply move from Key1 to Key2 without any interpolation at all...how?


ICECAP(Posted 1+ years ago) #2
Yep easy as.

Right click the first keyframe and then click one of the top envelopes (might be x y or z) then click the right hand big button with the graph on and select the one that are like a square wave (step).

In this case its Sphere01:Position - in some cases it could have seperate x y and z values.





You will have to do it with all the x y and z envelopes if they are there.

Close that window then do the same with the next keyframe but change the left hand graph button.

But that should make it snap from one keyframe to the other. Which i think is what you want to do.


Naughty Alien(Posted 1+ years ago) #3
i did that before...it does move from one keyframe to another one BUT from few sub-keyframes in between those two keys I have set...and I did set let say between frame 1 and 2..so at frame one, camera is on one position, and then frame 2 camera is instantly on different position, but without passing trough sub-keys..in max you cant see it, however, when i render to video or export to game engine..its obvious that its passing trough 3-4 additional keys..uhh..i remember that 3dsmax 3.0 had that option to disable interpolation between keys...I just dont know how to disable that stuff in version 8..aghh


ICECAP(Posted 1+ years ago) #4
Ahhh ok, yeah I understand. Have you tried looking at the animation in the time line graph thing? Sorry, I have forgotten the name and don't have max installed atm to check.
The expand button is on the left of the minimal timeline.
Sometimes that shows up curves and stuff that shouldn't be there.
I know thats not really answering your question about disabling the interpolation, but it could assist. I did a search on the net too, trying to find a solution, had no luck. I'll keep hunting round and see what I find.


Naughty Alien(Posted 1+ years ago) #5
..yup..I did check that and i set it to be all linear or step..but no matter what, there is always additional 3-4 sub frames between frame key 1 and frame key 2 .. im working on some animation stuff for cut scenes, and everything works except this thing for camera(it actually does work, its just that I dont want those frames in between)...


ICECAP(Posted 1+ years ago) #6
Yeah, I remember having a similar problem. The way I solved it was to create a keyframe right after the next one (as close as possible to it), then make sure the animation speed playback in blitz was sufficent enough to make it jump rather than ease.
After searching around for a while I have come to the conclusion that they have probably taken that feature out in the newer versions of max.
Maybe they called it something else and burried it somewhere. God only knows.


Naughty Alien(Posted 1+ years ago) #7
..i fixed it trough code (not B3D), so code simply 'jump' over 'fake'frames and continue next sequence..so its all fine now ;) but im still wondering and i really wanna know..how to delete those sub keys if i simply..dont want it..


ICECAP(Posted 1+ years ago) #8
Yeah as I said, from what I have read on the net, it seems to be a feature that has been left behind in an old version of 3dsmax.